PocketWizard device compatibility

The Raven is compatible with any PocketWizard radio that uses the E Release firmware protocol. The Plus IIIe and Plus IVe radios are currently being shipped from the manufacturer with the E Release pre installed. If you purchase a new FlexTT5, FlexTT6, and/or PowerMC2 from an authorized PocketWizard dealer, the radio will not have the firmware pre installed but will be eligible for a free upgrade to the E Release firmware. If you already own one or more of these units, you can upgrade your existing radios to the new firmware protocol.

 

Plus IIIe

Plus IVe

Nikon FlexTT5

Canon Flex TT5/6

PowerMC2  *Not compatible with the Paul C Buff DigiBee

 

*To learn more about the PocketWizard E Release, click here

*PocketWizard Plus IIIe requires E Release firmware version 2.716 or higher

*PocketWizard Plus IVe requires E Release firmware version 2.704 or higher

*PocketWizard FlexTT5 for Nikon requires E Release firmware version 4.105 or higher

*PocketWizard FlexTT5/6 for Canon requires E Release firmware version 8.003 or higher

*PocketWizard PowerMC2 requires E Release firmware version 4.203 or higher